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Chapter 1 Software Introduction 

 

1.1 Product description 

This manual mainly involves the support and operation of GAOTek PC-side demonstration software for 

USB cameras, Gigabit Ethernet port area scan cameras, and Gigabit Ethernet port line scan cameras. 
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1.2 Overview of functional features 

 Device list and device connection, collection, disconnection, and batch operations 

 Device preview and status parameters, software zoom and pan, take photos, and video 

 Device attribute tree, including attributes and operations supported by the current device 

 Menu bar language switching, skin switching, IP configuration, firmware upgrade, file settings 

 

1.3 Software download 

  Download address:  

 

 

 

 

 

Chapter 2 Installation and Startup 

 

2.1 Installation steps 

 After the software installation package is downloaded, double-click to enter the installation and 

select the SDK language. 
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 After the language is confirmed, select "OK" to enter the installation 

interface 

 Click "Next step" to eenter the selection interface and check the device driver 

that needs to be installed. 

 Click "Next step" to eenter the software installation directory selection. 

 Click "Next step" to eenter the shortcut creation interface 

 Click "Installation" to eenter the installation. If there is a problem that the signature cannot be 

verified during the installation process, and the signature verification of individual system 

software fails, choose to always install this software. 

 Click "Next" to enter the new version of the demo software installation process 

 Click "Install" to install. 

 Click "Finish" to complete the installation of the new version of the demo software. 

 Complete the entire installation process 

 

Overview of functional features 

 Device list and device connection, collection, disconnection, and batch operations 

 Device preview and status parameters, software zoom and pan, take photos, and video 

 Device attribute tree, including attributes and operations supported by the current device 

 Menu bar language switching, skin switching, IP configuration, firmware upgrade, file settings 

 

 

2.2 Startup 

                                    

Double-click the desktop shortcut to launch the software  

 

 

 

Chapter 3 Basic Function Introduction 

 

3.1 Basic interface introduction 
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The above interface is the main interface, with a device list on the left, a screen 

preview window in the middle, a device attribute list on the right, and a menu bar 

with some basic functions at the top. Next, the functions will be introduced one by one based 

on these four modules. 

 

 

 

Chapter 4 Menu Bar 

 

4.1 IP configuration tool 

Tools->IP Configuration Tool->Enter the IP configuration tool of the network port camera, select any 

network port camera in the device list on the left, and click the "AutoSetIP" button to perform one-click 

IP settings. For more function introduction, please refer to the software installation 

directory/Document/"Gigabit Network Camera User Guide.pdf". 

 

4.2 Firmware upgrade 

Tools->Firmware Upgrade->Enter the camera's firmware upgrade tool, select any device in the device list 

on the left, click the icon 1 button to select the firmware, and then click the icon 2 button to perform the 

upgrade operation. 

 

4.3 Language 

Help->Language can switch languages and display the currently used language. The software supports 

three languages: Chinese, English, and Traditional Chinese. 

 

4.4 Color theme 

Help -> Color theme, you can switch skins and display the currently used skin. The software supports 

black and white skins. 

 

4.5 About 
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Help->About, check the current software version. 

 

Photo settings 4.6 

File->Photography Settings->The following interface pops up to set the captured image format, 

naming prefix, and file storage path. "Capture" is used to render the current frame of image to the 

interface and display it without saving it. Click "Save”” button will be saved to the file. 

 

4.7 Recording settings 

    File->Recording Settings->The recording setting interface pops up to set the video quality, 

compression method, and save path during recording. 

 

 

 

 

 

 

Chapter 5 List of equipment 

 

 5.1 Camera connection 

    After the software is opened, all currently connectable USB cameras and Gigabit Ethernet cameras 

will be automatically enumerated on the left. Select any camera and double-click or click the icon button 

to connect to the camera.  

 

5.2 Camera disconnection 

    Select a connected camera and click the icon button to disconnect the camera. 

 

5.3 Camera preview 
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   Select the connected camera, click the icon button to start the camera's 

acquisition and display the preview image in the central area, or right-click to start 

the preview, or click the acquisition button in the central area to start the camera's preview. 

  

 

5.4 Stop collection 

    Select the camera being previewed and click the icon button to stop the camera's collection so that 

the preview will no longer be refreshed. You can also right-click to stop collection, or click the stop 

collection button in the center area to stop the camera's collection  

 

5.5 Batch operations 

      The two buttons shown in the figure can respectively stop/start acquisition of all connected 

cameras in the list 

 

 

5.6 View device information 

    Select any camera to view the camera's device information in the lower left corner, as shown in the 

figure. 

 

 

 

 

Chapter 6 Property List 

 

6.1 Device control 
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This attribute is used to view the current device information, including 

firmware information, serial number, nickname, etc. 

 

6.2 Image format control 

This property is used to set the camera's resolution, rotation, mirroring, Binning mode, and pixel 

format. 

 

6.2.1 Resolution and ROI 

The camera displays images at the maximum resolution by default, and usually a camera has 

multiple common resolutions. When the user is interested in a certain part of the image, the camera can 

set the ROI to output the image of the area of interest. Setting the ROI can reduce the transmission data 

bandwidth and increase the frame rate to a certain extent. As shown in the figure, the width, height and 

offset of the ROI can be set. 

 

6.2.2 Binning mode 

    The Binning function combines multiple adjacent pixels into one pixel, reducing resolution while 

increasing image brightness. Currently, area scan cameras support four Binning modes, namely 

 SUM2*2 combines pixels according to the 2*2 rule and takes their sum; 

 SUM4*4 combines pixels according to the 4*4 rule and takes their sum; 

 AVG2*2 merges pixels according to the 2*2 rule and takes the average value; 

 AVG4*4 merges pixels according to the 4*4 rule and takes the average value; 

For line scan cameras, software Binning can be performed in the right-click menu of the video 

preview window. For detailed operations, see Chapter 8. 

 

6.2.3 Mirroring 

Mirroring is divided into horizontal mirroring and vertical mirroring, which can be processed on the 

software or supported on the underlying hardware. The two mirroring principles are as follows: 

 Horizontal mirroring flips the camera image left and right; 

 Vertical mirroring flips the camera image up and down. 
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6.3 Collection control 

This property is used to view and set the camera's acquisition mode, frame rate, 

frame rate mode, etc. 

 

6.4 Exposure control 

This property is used to view and set the camera's exposure mode, brightness, exposure time, anti-flicker 

frequency, etc. 

 

6.4.1 Brightness 

Camera brightness is the reference brightness when adjusting images in one automatic or continuous 

automatic exposure and gain modes. If the camera is exposed manually, the brightness parameter is 

invalid. 

After setting the brightness, the camera will automatically adjust the exposure time or analog gain to 

make the image brightness reach the target brightness. The larger the brightness setting, the brighter the 

image will be adjusted in automatic exposure or automatic gain mode. The smaller the brightness setting, 

the darker the image will be adjusted in automatic exposure or automatic gain mode. 

 

6.5 Trigger control 

This property is used to view and set the camera's trigger mode and strobe mode. 

 

 

 

 

 

 

6.5.1 Trigger mode 

There are three trigger modes: continuous trigger, software trigger, and hardware trigger. The details are 

as follows: 
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 Continuous triggering means that the camera continuously collects 

images according to the frame rate, which is the default mode; 

 Software triggering means that the camera sends a command through the upper-

layer software to trigger a collection action; 

 Hardware triggering: The external device is connected to the camera through the camera I/O 

interface, and the external device sends a trigger signal to the camera to capture images. The 

hardware trigger can set the number of trigger images, trigger delay, trigger interval, external 

trigger edge, and external trigger removal. Bounce time, strobe mode, etc. 

 

6.5.2 Triggering method 

    Edge triggered mode. You can select the upper edge or lower edge as the trigger condition on the 

interface. When the trigger terminal receives a valid trigger signal, the camera starts to collect a frame of 

images and transmits it to the host. Each valid edge corresponds to a trigger, and only one frame of image 

is output. Before the last frame of image acquisition is completed, repeated trigger signals will be ignored.  

 

For example, if the camera's exposure time is set to 10 milliseconds and the effective trigger signal is set 

to rising edge trigger, then within 10 milliseconds, even if there are multiple rising edge signals, only one 

frame of image will be triggered. 

Level triggered mode. You can select high level or low level as the trigger condition on the interface. 

When a trigger signal is at a valid level, the camera starts to collect a frame of image and transmits it to 

the host. After the frame collection is completed, if the signal is still at a valid level, the camera starts to 

collect the next frame of image and transmits it to the host until the trigger The signal changes to an 

inactive level. 

 

6.5.3 Trigger delay 

Trigger delay means that when the external trigger signal is generated, the camera does not start exposure 

immediately, but delays for a certain period of time before starting exposure. When the delay is set to 0, it 

means there is no delay. 

 

6.5.4 External trigger debounce time 
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When the external trigger terminal TRIG_IN is connected to a mechanical 

switch, false triggering may occur due to contact jitter. There is a hardware filter 

circuit in the camera, and the debounce time can be set to filter out the jitter, as shown in 

the figure below for t0 and t2 jitter: 

 

When connecting an electronic switch, debounce is not required and the debounce time can be set to 0. 

 

6.5.5 Strobe 

The strobe signal is an output signal, corresponding to the output IO port with index 0. 

In automatic mode, the strobe is synchronized with the exposure. When the sensor starts to expose, the 

strobe turns on. When the sensor ends the exposure, the strobe turns off. This mode is used by default. 

In semi-automatic mode, the strobe timing is completely controlled by software programming, which 

requires setting the delay and width. 

When an external signal is generated, the strobe signal begins to output for one cycle, and the timing is as 

shown below (assuming that both the trigger and strobe output are active high): 
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Td is the delay and Tw is the pulse width. 

 

 

6.6 Analog control 

This property is used to view and set manual exposure simulation gain, sharpness, LUT user lookup table, 

noise reduction, etc. 

 

6.6.1 LUT user lookup table 

A LUT lookup table is a grayscale curve. Through the settings of LUT, users can stretch and highlight the 

grayscale range of interest. It supports three methods of dynamic generation, customization, and camera 

preset. The details of these three methods are introduced below: 

Dynamically generate the camera's default LUT curve, which can be adjusted by gamma value and 

contrast; Camera presets include several LUT curves built into the camera; Custom user-defined mapping 

curve. 

 

6.6.2 Sharpening 
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The camera has a sharpening function that can adjust the sharpness of the edges 

of the image. The sharpness parameter defaults to 0 and is not enabled. 

 

 

 

 

 

 

 

6.6.3 2D noise reduction 

Some cameras support noise reduction. Turning on 2D noise reduction can achieve the effect of 

maintaining edges, reducing noise and smoothing, improving the signal-to-noise ratio of the image, and 

further improving the imaging quality of the image. 

 

6.6.4 3D noise reduction 

The principle is similar to 2D noise reduction, but multiple frames of images at different times are 

collected from the image frame queue for sampling calculation, and the calculation speed is slower. 

 

6.6.5 Algorithm noise reduction 

A solution that uses software algorithms to improve the signal-to-noise ratio. Currently, it supports Gauss, 

Bilateral, and A3 algorithms. 

 

6.7 Color conversion control 

   This attribute mainly involves image color correction and conversion, including white balance, ISP 

version selection, saturation, Raw2RGB algorithm, etc. 

 

6.7.1 ISP version 

ISP stands for Image Signal Processing. The camera integrates several sets of image signal processing 

engines, and different camera versions have different versions. 
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6.7.2 White balance 

Color correction based on different light source lighting conditions. You can adjust the R, G, 

and B components in the image so that the white area remains white at different color temperatures. 

 

It also supports regional white balance. Users can click "Set White Balance Window" to pop up the 

following interface to set the area to be referenced. 

 

6.7.3 Saturation 

Saturation refers to adjusting the brightness of the image color under a color camera to make the image 

more full, gorgeous and close to the real thing. The smaller the value you set, the darker the image will 

look; the larger the value you set, the richer and more colorful the image will look. 

 

6.7.4 Raw2RGB algorithm 

A collection of algorithms that convert original image data RAW into RGB format, supporting multiple 

algorithms. 

 

6.8 Shadow Correction 

   This attribute contains various image correction algorithms. The algorithms supported by area array 

cameras and line array cameras are different. Let’s introduce them one by one below. 

 

6.8.1 Lens distortion correction 

The camera lens will cause distortion due to deviations in manufacturing process accuracy, resulting in 

image distortion. This algorithm is used to restore and correct the distorted parts to a certain extent. Click 

the Shadow Correction->Lens Distortion Correction "Edit" button to pop up the following dialog box for 

specific correction operations. 
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 You need to prepare a black and white calibration plate and place it completely 

within the camera screen. If you already have a complete picture of the calibration plate, you 

can also directly load the image. After clicking "Capture" or loading, the software will calculate the set of 

landmark points and display the result. Come out, and then click the "Calibrate" button to calculate the 

calibration result, and finally apply it to the camera's imaging screen. 

 

6.8.2 Color point correction 

It means dead pixel correction. In digital cameras, dead pixels refer to the photosensitive component unit 

that cannot capture light correctly. If the photosensitive component has dead pixels, it will directly cause 

imaging defects. The software uses algorithms to correct bad pixels on the image. Click the Shadow 

Correction->Color Point Correction "Edit" button to pop up the following dialog box for specific 

correction operations. 

 

When entering the dialog box, an image will be automatically taken and displayed. If color point 

correction is enabled and the camera's own color points are automatically recognized and presented on the 

image, the "Camera Color Points" text box will count the number of camera's own color points; if the 

above conditions are not met, is 0. 

Click the "Dead Pixels" and "Colored Pixels" buttons in the icon to analyze the camera's dead pixels. 

Colored pixels are bright spots that are much brighter than the surrounding pixels, and bad pixels are 

those that are much darker than the surrounding pixels. point. 

Click the "Apply" button to display the bad pixels analyzed in this analysis on the camera preview image. 

It only works for this camera switch and will not work if you restart the camera. 

Clicking "Save to Camera" will take effect permanently, but it will affect the camera startup time. 

 

6.8.3 Flat field correction 

For area array cameras, flat field correction is also called fixed background noise correction. It is caused 

by various reasons such as uneven illumination, inconsistent response between the center of the lens and 

the edge of the lens, and inconsistent response of each pixel of the imaging device. The bright and dark 

field images are calculated through software algorithms. and correct. Click the Shadow Correction->Flat 

Field Correction "Edit" button to pop up the following dialog box for specific operations. 
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First cover the lens with an occlusion, take a dark field image, then take a bright 

field image against white paper or a pure white object, and then click the "Generate" button to 

calculate the correction parameter set. When Param valid appears When prompted, check the "Enable" 

box to enable the calculated parameters to affect the camera preview image. 

 

 

6.9 Digital IO control 

This attribute is used to view the I/O electrical characteristics and line status and set the line mode 

 

 

 

 

 

 

 

 

 

 

 

6.9.1 Line mode 

Project  Access power restrictions  

Trigger input TRIG  Voltage 5~24V 

Strobe STRB  Maximum current is less than 50 mA  

Normal input IO  Voltage 5~24V 

Normal output IO  Maximum current is less than 50 mA 
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6.9.2 Line status 

Ordinary output port. The output status has high level/low level (high level means on, low level means 

off), which is controlled by software. It is flexible but not very fast, so it is not suitable for applications 

that require very precise delay and high speed. 

 

Ordinary input port. The software calls the API once, and the hardware captures the interface status once. 

In non-continuous reading mode, interrupt response is not supported. Suitable for medium and low speed 

acquisition input. 

 

6.10 User set control 

The software presets a batch of parameter sets for loading the values of each attribute in the attribute list, 

and switches different user sets to load different parameter sets. 

 

6.11 GigEVision control 

This attribute is mainly used to view and set Gigabit network card camera network-related attributes, 

including data packet size, heartbeat packet, IP address, gateway, etc. 

 

 

 

 

 

 

 

 

Chapter 7 Image Preview and Status 
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7.1 Preview toolbar 

 Software to enlarge image 

 Software to reduce image 

 Display images adaptively or in original image proportions 

 Start or stop collection 

 Take a picture and save it to the file location specified in the menu bar->Photo settings 

 Record a video and save it to the file location specified in the menu bar->Video Settings 

 

 

7.2 Status bar 

 Check the current resolution of the camera 

 Check the current software zoom image ratio 

 View camera acquisition frame rate 

 View camera preview frame rate 

 Statistics of the total number of frames collected 

 The number of frames dropped by the network port camera 

 Number of network port camera retransmissions after frame loss 

 Pixel coordinates 

 RGB value at current pixel coordinates 

 YUV value at current pixel coordinates 

 Network port camera data packet size 

 Camera temperature 

 

 

 

Chapter 8 Unique Functions of Line Scan Cameras 

 

8.1 Row rearrangement 
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   This function is usually used with high-speed light sources to achieve time-

sharing stroboscopic function. For example, the light source is set to three 

brightness levels. After the camera scans a line, the light source switches to another 

brightness. In this way, each group of 3 lines in the overall imaged picture has different brightness. 

Through the camera's "3-row rearrangement" function, rows with the same brightness can be put together 

for easy processing. For example: 123456789 before rearrangement, 147258369 after rearrangement. 

It can be operated through the video preview window->right-click menu->row rearrangement. 

 

 

 

8.2 Software Binning 

   The Binning function of line scan cameras is similar in principle to the Binning function of area scan 

cameras. They both merge adjacent pixels into one pixel, but the sampling rules are different. Sampling 

and reorganization are performed by rows or columns. 

   It can be operated through the video preview window->right-click menu->software Binning. 

 

 

8.3 One-click flat white balance 

   This function performs white balance during flat field correction to correct image distortion. Click the 

"Edit" button on the right side of the property list->Shadow Correction->One-click Flat White Balance to 

pop up the following dialog box for operation: 

 

First collect a dark field image, calculate the image mean, adjust the exposure time, then collect a bright 

field image and perform white balance and FPN calculations at the same time to obtain the calculation 

results. Clicking the "Save" button will save the results to a file. Checking "Enable" will apply the 

calculation results to the camera and present them in the preview window. The image has changed a lot 

compared to before, and there are no longer obvious stripes. 

 

 

 


